CHAPTER IV

DEVELOPMENT OF THE SIMULATOR

4.1 Computer Program of Distillation Calculation

The program developed by using ¢ language could be run under
Microsoft Windows version 3.1 or later. The personal computer which have at
least 386DX microprocessor with 4 MB RAM and VGA monitor could be run this
simulator.  The 486 DX2 with 8MB RAM is recommended. This simulator is
composed of four parts as follows,

411 Input Data

Base on chapter in, the rigorous model that requires a lot of input
data is chosen in this work. The input data required for solving distillation
problems are difficult to enter them into computer program due to its complexity.
Then, the input tools are developed to enter the data easily. The details of input
dialogs are shown as follows:

1) Components selection

Users can select components in the list which is shown on this
dialog. It allows the user to select the maximum number of components up to 10,
The warning message is automatically shown when the list of selected
components IS changed. The selection of components must be done otherwise
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Other parts of program cannot be run before selecting components, (refer to figure
41)

'Select Components y

List ot Compounds Seleted Compounds

1-1-dichlorotetrafluorosthane | |
1-1-difluoroethene

1-1-dimethyl cyclohexane

1-1-dimethiylcyclopentane

1-2-butadiene I

-2-dich brotetraflUoroethane

Z-Bentadlene = '
3-butadiene Indices Box

butene e
butyne

chlorobutane +
ecene 3:r - 1

-neptene Get Compounds Close

Set Compounds

1-methyl-3-ethylbenzene
1-methyl-4-ethylbenzene
1-nonene

D Deselect Mode

Figure 41 The Dialog for selecting component.

2) Selection of thermodynamic property models
Thermodynamic properties of vapor and liquid are estimated
from one of three model, namely Ideal gas, Soave Redlich Kwong and Peng-
Robinson models.  Users can select the appropriate model from menu item
‘Properties package” in the Select menu. The PR s a default of this program.
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3) Column configurations selection
Users have to specify the column configurations, including
* the number of stages
* the number of feeds
* the number of side streams
+ the number of energy streams (Side exchanger)
o reflux ratio
The maximum number of stages is up to 100. Itis
illustrated in figure 4.2
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> Figure 4.2 The Column Configuration dialog

4) Feed dialog determination
The operating condition of feed must be specified in this
dialog are the feed temperature, pressure, flowrate with the composition, and the
location of feed stream. This dialog s shown in figure 4.3.
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Feed Condition
Feed No. 1

K |
bar s
kgmole/hr +

Figure 4.3 The Feed Dialog

Users can call this didog from the command menu or the
active area of Feed in schematic diagram shown in the main window Users can
input feed composition of each component in the didog which is displayed when
the " .." button is clicked. The didog is shown in figure 4.4

Users may input molar flowrate for each component. This
program will normdize the molar composition after the ™ ™ button is clicked.



Input Mole Fractions

Selected components Mole fractions

methane
2 n-butane
3 n-pentane

oK Cancel

Figure 4.4 The Didog for input feed composition.

5) Vapor/ Liquid top product determination
Users select this didog from the command menu or activate it
by double choking on the top product stream in the schematic diagram of
distillation column. The data entered into the program consist of temperature,
pressure and flowrate. There are two kinds of probable product which IS liquid or
vapor, depending on the condition of temperature and pressure. The didog IS
shown in figure 4.5.



A

har

kgmole/hr

Figure 45 The Top Product Dialog

6) Bottom product determination
This didog is similar to the top product as shown in figure 4.6.
The bottom product ( ) is liquid side stream from reboiler with flowrate
which can be determinated by this program.
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Figure 4.6. The Bottom Product Dialog
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7) Vapor/Liquid side stream determination
A dialog for determining the side stream data which
consists of flowrate and location of each stream can he chosen from Edit menu.
It is convenient to input data in the didog as illustrated in figure 4.7,

[ H
Liquid Sidestream No. 1

kgmole/hr

E

Figure 4.7 The Side Stream Didog

8) Determining of heat transfer to/from each stage
Data of the heat transfer to or from each stage consist of as
heat transfer rate and it’s location  User have to enter heat transfer rates to or
from all individud stages except stage 1 (condenser) and stage N (reboiler).
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Figure 48 The Didog for Entering Heat Transfer Data

Before running this program, it is recommended to check the input
data from menu item “Check Input™ presented in Report menu. However, the
data can be changed by selecting the input didog and entering new data in the
didog of the data which users want to change.

Table 4.1 summarizes the input data that must be input into this
program.



Table 41 Summary of Input Data

Input Data
Mixture
Column Configurations

Feed

Product
- Vapor top product
- Liquid top product
- Bottom product
Side streams
- Vapor side streams
- Liquid side streams
Heat transfer rate to or
from stage

Details of Input Data
Component
The number of stages
The number of feeds
The number of side streams
The number of heat transfer rates
Reflux ratio
Feed location
Flowrate
Temperature
Pressure

Flowrate
Temperature
Pressure

Flowrate
Stream location

Heat transfer rates
Stream locations

34
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4. .2 Database

This program is linked to the database developed by using €
language.  Thermodynamic properties and vapor-liquid equilibrium shown in
chapter Il can be calculated using data from the database and are sent to the
calculation module, for solving the distillation problem.

Users have to select the model for estimating the thermodynamic
properties of all components. For a nonideal case, Soave Redlich Kwong or Peng-
Robinson will be used for calculating the properties.

4.1.3 Computational Procedure
The computational procedure used in this program was modified
from Boiling Point method. The details of development was discussed in 4.2,

4,14 Output

The results of calculation are presented in tabular form which is
displayed on Windows. Two windows show the results of simulation. The first
window exhibits temperature, pressure, flowrate with the composition of each
component, and enthalpies of vapor-liquid sidestreams, vapor-liquid top products
and bottom products, see figure 49. The other displays temperature, pressure,
and composition distribution in the column, figure 4.12. In addition, figure 4.13
presents the temperature distribution with respect to the equilibrium stages.



Top Product: Stage 1

Vapor Distillate = 0.000
Liquid Distillate = 22.500
Temperature = 301.832
Pressure =6.890 Bar
Components

1 n-butane
2 n-pentane
3 propane

K

kmolefhr
kmolefhr

Result of Distillation calculation

Yapor comp..
Liquid comp.
Composition
Vapor Liquid
0.1575 0.3479
0.0096 0.0633
0.8330 0.5888

| ES A
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Figure 4.9 The output, window



comp  n-butane
comp 2 n-pentane
comp 3 propane

Vapor Composition

Stage

No. Compl Comp2 Comp3
1 01708 0.0283 0.8008
2 0.3306 0.1599 0.5095
3 0.3464 0.3407 0.3129

Vapor Composition Profile

OK

[

Figure 4.10 The vapor composition window.
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comp 1 n-butane
comp 2 n-pentane
comp 3 propane

Liquid Composition

Stage

No. Compl Comp2 Comp3
1 03306 0.1599 05095
2 03551 04392 0.2058
302707 0.6298 0.0995

W T

Figure 4.11 The liquid composition window.

Liquid Composition Profile

OK
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B oo Stage Varable i kG bR
Stage Variables QK

Reflux Ratio = 2.0000

Stage Press Temp Flowrate Feed Draws Duty

kmole/hr

No. Bar K ' L v L kJ/hr

1 6.89 301.83 0.000 45.000 0.00 0.00 2250 1209877.9

2 6.89 321.35 67.500 41.279 0.00 0.00 0.00 0.0

3 6.89 33717 63.779 90.758 45.80 0.00 0.00 0.0

4 6.89 351.02 67.458 88.767 0.00 0.00 0.00 0.0

5 6.89 362.30 65.467 23.300 0.00 0.00 0.00 -1354649.0
« |

Figure 4.12 The stage variables window
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Figure 4.13 The temperature profile plotted on the output window.
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Figure 4.14 The vapor composition profile plotted on the output window.
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Figure 4.15

The liquid composition profile plotted on the output window.
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Table 42 Summary of the output

Output Details of Output
Check To check Input Data
Product Flowrate
- Top product Composition
- Bottom product Temperature
- Side stream Pressure
All stages Temperature distribution

Composition distribution

4.2 The Details of Calculation Procedure

The data input window is used to declare variables for the
calc ating part. The calculation procedure is shown as follows:

1) All of variables have been defined as zero when the column
configuration is specified by users. One of 2 dimensional array equal to the
number of components and the other IS the number of stages rs the second
dimension.

2) The input data rs changed to the single or two dimensronal
arrays before calculating.

The single dimensional arrays are temperature (T), pressure (P),
feed temperatures (Tj)1feed pressures (Pf), feed flowrates (F), vapor (V) and liquid
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(L) flowrates, vapor ( ) and liquid () sidestreams and heat duties (Q). The
indexes of those arrays are represented by numbers of equilibrium stage.

The two dimensional arrays are the phase equilibrium constant (K)
and compositions of liquid, vapor and feed. Both indexes of the arrays are
represented by numbers of components and equilibrium stages, respectively.

3) Variable initialization

The liquid bottom product from reboiler (LN) is calc ated from
overall material balance that given in equation (3-6).

The pressure of each stage are defined by equation (4-1).

SRR )
where
PNis pressure of reboiler (Bar).

Pj is pressure of condenser (Bar).

The initial temperature of each stage is assumed to be linear from
condenser to reboiler as shown in equation (4-2).

Tj=T1j- 1 (1A~ A (4-2)
where
Tn is temperature of reboiler (K).

T1is temperature of condenser (K).

The vapor interstage is defined from overall material balance of
condenser.
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i
Vapor top product (V))

Condenser

1 Liquid top product ( 1)
V2 Li

Figure 4.16 The model of the condenser (stage 1).

The model in figure 4.16 is assumed to be no vapor sidestream ( 1)
and feed (F). Then the overall material balance is yielded as

V2=VI +UL + LI (4-3)

The equation (4-3) has two unknown, but we can find L1 from
reflux ratio. The reflux ratio is defined as the molar ratio of the liquid returning
to stage 2 to the total flow of the liquid and vapor top product.

R=y ( #V) (4-4)
or
Lj=RItyv]) (4-5)

Substitute Lj in equation (4-3) by (4-5) to find V2

V2 = VI + UL + R*(UL+V1) (4-6)
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This program initializes V3to VNto be equal to V2,

4) The simulator firstly calculates from ideal condition to estimate
the liquid composition in each stage as the initial guess.

5) Bubble temperature is calculated to find new T.

6) Temperature is rechecked by equation (3-30) and equation (3-
31). Program terminates when the condition is true.

New V is determined from the method discussed in chapter Il
Heat duties are calculated from equation (3-5) for the condenser and from
equation (3-22) for the reboiler.



START 1

Get the input data from window dialog

Main Calculation, Initialize tear variables T and V

Calculate K|

Find x from solving tridiagonal matrix

Normalize x

Fine new T from bubble temperature

Yes

STOP

No

Calculate the vapor and liquid enthalpy from selected correlations.J

Calculate new V, L and heat duty.

Figure 4.17 Flowchart of this simulator
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4.3 An Qverview of The Simulator
The distillation simulator displayed in this work is a Windows
application consisting of the following main components:
— The frame window with the menu system, minimize icon, and
maximize icon. The window has a title as ‘Distillation Column”.
— The conventional distillation column shown on main window
displays the input didog of feed, top product, or bottom product
when the left button is clicked at the active areas.

=| IZ Distillation Column
JruTUﬂ(l_q le) (Select) (Eqit) (Report) (Bun) Help

Distillate [Vapor]
>

L

Distillate (Liquid]

Feed

%

Bottom

DISTILLATION COLUMN

Figure 4.18 The main window of distillation simulator.

The Menu shown on the main window consrsts of many commands. The
details for using each command is given as follows
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431 The File Menu
The File menu consists of commands to start and to exit the
application. The details of each command are shown in Table 4.3.

Table 43 Summary of the commands in the File menu.

Command Function
New To create a new the distillation case
- show the column configuration
dialog for enter the data.
- show the window for select
components.

Exit To exit from the application.

4.3.2 The Selecting Menu
The Selecting menu provides commands for selection of
components and methods for estimating the thermodynamic properties. The

commands are shown in Table 4.4.



Table 44 Summary of commands in the Selecting menu

Command Function
Property Package... To select @ method to calculate the
thermodynamic properties.
|deal Case |deal case
SRK Soave Redlich Kwong correlation
PR Peng Robinson correlation

Components Select components

51
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4.3.3 The Edit Menu
The Edit menu provides commands to edit input data
Table 45 summarizes the commands in Edit menu.

Table 45 Summary of the commands in the Edit menu.

Command Function

Feed To input flowrate, conditions and
location of feed streams.

Product To input flowrate, temperature and
pressure of product

Side stream To input flowrate ad location of side
streams

Energy Stream To input heat transfer rate and location

of streams (except the condenser and
reboiler duty).
Column Configuration Input Column Configurations, including
* - number of stages
o number of feeds
o number of side streams
* number of energy streams
o reflux ratio

4.3.4 The Report Menu
There are several commands for showing the input data and
the results of calculation. Table 4.6 summarizes the commands in the Report
menu.
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Table 46 Summary of the commands in the Report menu.

Command Function
Check To show data that are input by user.
Input Data - Column Configuration
- Initial guess of product
- Feed

- Sidestreams
- side exchanger

Result To show the result of calculation.
Table - Product
- Vapor and liquid composition
Stage variables To show temperature, pressure and flow
in column
Graph Temperature profile

4,35 The Run Menu
The Run command is used to run the program for solving
distillation problems after all of necessary input data are defined.

43.6 The Help Menu

The Help file is very useful for users to start the simulator.
The detail of help is following.

- How to use the simulator.

- Suggestion for input data.

- The column convention.

- The list of message from simulator.

The Help file of Distillation simulator 1S shown in figure 4.19.



Help for Distillation .Column
File Edit Bookmark Help

*1 Search | jack | Hstary

Figure 4.19 The Help file for distillation simulator.
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